Posts
1145
Comments
890
Trackbacks
1
Scaffold-DbContext doesn’t appear to work with EF Core 1.1

Are you surprised?  Me either.

Given this NuGet Package Console command:

Scaffold-DbContext -Connection "data source=MyServer;initial catalog=MyDb;integrated security=True" -Provider "Microsoft.EntityFrameworkCore.SqlServer"

where I’ve obviously replace my actual server name and database name, one gets this error:

Could not load file or assembly 'System.Data.SqlClient, Version=4.1.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. The system cannot find the file specified.

Well, that’s because EF Core 1.1 along with the SqlServer package requires SqlClient version 4.3.0

Fantastic.

posted on Friday, November 25, 2016 11:42 AM Print
Comments
No comments posted yet.

Post Comment

Title *
Name *
Email
Url
Comment *  
Please add 4 and 8 and type the answer here: